After I paste within an images URL from Flickr right into a wordpress publish it auto embeds it in to the publish. In some way it's getting set to some default width of 500px. How/where will i change this? I simply aren't able to find any documentation for this, arg!

Note: I'm while using twentyten theme.

EDIT:

To explain, this isn't a stylesheet problem.

Basically paste this right into a publish:

http://www.flickr.com/photos/davebryan/5755930575/

Wordpress auto embeds it and changes it for this:

<img width="500" height="331" alt="" src="http://farm6.static.flickr.com/5267/5755930575_eee9e7c727.jpg">

Where's it obtaining the width and height?

It's auto-embedding http://codex.wordpress.org/Embeds using http://oembed.com through the file wordpress-includes/class-oembed.php

You are able to uncheck autoembedding in Administration > Configurations > Media SubPanel and hang maximum width and height.

You may also make use of a shortcode for size, i.e.: [embed width="123" height="456"]...[/embed]

Do this:

#content img {
    margin: 0;
    height: auto;
    max-width: 640px;
    width: auto;
}

Also see here: http://wordpress.org/support/topic/twenty-ten-11-ignoring-image-width-resizing

Beside songdogtech's answer I have observed that when you attend flickr link within the discussing area in the top website you are able to press "Different options to talk about" it will highlight option "Grab the HTML/BBCode" there you will notice the autoembedded code that gone to live in the editor.

To be able to p-activate this feature you are able to follow songdogtech's answer.

Additionally to songdogtech's answer, Twenty Ten also sets this content width within the styles function.php file. See line 47, increase accordingly.

if ( ! isset( $content_width ) )
$content_width = 640;