I'm using wamp and have to know why I get server error messages appear in most browsers. (see grab). I've switched error display off in php.ini and can't see any place in the httpd.conf file that might be exhibiting these. I'd appreciate outside assistance regarding the way i can trobleshoot and fix this issue. If anybody requires further code or information, I'd gladly supply at fiddle.

I'm using php5.3.5 and apache 2..53.

Thanks

enter image description here

Are you certain display_errors is not being set at runtime by some function inside your code? ini_set may be used to set that value at runtime, as proven within this PHP doc example:

<?php
echo ini_get('display_errors');

if (!ini_get('display_errors')) {
    ini_set('display_errors', 1);
}

echo ini_get('display_errors');
?>

display_errors is changeable PHP_INI_ALL (documentation).

What this means is it may be enabled in .htaccess, or perhaps in a running script using ini_set(). Look at your .htaccess files observe that the server (in arrears config) inspections .htaccess files in parent sites too - therefore if your internet site is in /var/www/example.com/htdocs, look for .htaccess in each one of the sites within this path.

i've switched error display off in php.ini

Have you make sure that the php.ini file you transformed/checked was the main one PHP is applying? (proven by phpinfo())

Have you restart the webserver after altering the php.ini file?

What grab? When the q's above don't resolve your condition please supply the text from the error message.

appears like you're using zend framework. should you don't want to exhibit error messages. (anyway turning off errors will not fix them)

option 1. change application atmosphere. edit your bootstrap file (in public places directory) find following lines

defined('APPLICATION_ENV')
|| define('APPLICATION_ENV', (getenv('APPLICATION_ENV') ? getenv('APPLICATION_ENV') : 'development'));

to following

defined('APPLICATION_ENV')
|| define('APPLICATION_ENV', (getenv('APPLICATION_ENV') ? getenv('APPLICATION_ENV') : 'production'));

option 2. edit the application.ini (in application/configs directory) file. change all phpSettings.display_errors=1 to phpSettings.display_errors = .

anyway I suggest using option 2.

but don't forget turning off errors will not fix them. should you publish your code might be we are able to help.

In the OP's comment:

In php info file, display_errors is proven as on. Within the php.ini file it's disabled: display_errors = On. how can this be happening. I've checked for multiple ini files, but could only begin to see the 1.

When the choice is said out in php.ini, it isn't disabled: this means "use default". IIRC, the default here's On. Add the road display_errors = Off to php.ini.