i've installed my dependencies for Catalyst in ~/perl5/lib/perl5 using local::lib

I wish to run my application under Apache2 using mod_fcgid, however the fastcgi perl script cannot discover the modules during my custom path. How do i specify that (apache config?) my custom lib dir will be incorporated within the Corporation directory without clearly hacking it into myapp_fastcgi.pl? I wish to have the ability to move my application between servers which have the perl includes set up in different sites.

Thanks, Take advantage of

You are able to set the atmosphere variables with DefaultInitEnv. You most likely want something similar to this, however with your family includes too,

DefaultInitEnv PERL5LIB /home/rob/perl5/lib/perl5

You may also do such things as setting your application config like this too,

DefaultInitEnv APPNAME_CONFIG /srv/app/appname.conf