A couple of several weeks ago I published this because I attempted to follow along with all the Google instructions, perfectly, for establishing a website together with your Google Application Engine application.

I still could not get my new domain (bought through Google) to operate correctly. After a little of triple checking during my Google Applications account and DNS setting tweaks (using the ENOM registrar which Google uses), I threw in the towel and figured I'd just wait a couple of days to determine what went down.

Surprise, following a couple of days my domain began to operate with no problems and I have started to question when the problem was that it requires Google a little of your time to obtain everything setup on the website finish.

Today, I have once more released an Application Engine application and experienced the entire process of buying a website through Google and configuring it in the search engines Applications. After following Googles instructions, likely to my new domain indicates a normal welcome page (seen here.)

I've got a hunch that I have setup my site properly and that i should most likely you need to be patient. However, I have never witnessed Google documentation proclaiming that the setup may require sometime, so I am still a wee bit skeptical.

How lengthy should I must watch for my domain, Applications site and Application Engine application to become fully setup and functional against my new domain?

Whenever you register your brand-new Domain title, the brand new Domain will tipically take between 24 to 96 hrs to propagate.
When the Domain is propagated, you are able to setup your Google Application Engine application in couple of minutes.

Usually you will have to tweak the DNS of the Domain for a few procedures that doesn't require a lot more than ten minutes of labor:

  1. TXT record creation to permit Google to ensure you have that Domain
  2. CNAME record creation to map your Application engine application towards the new registered Domain