at this time, i personally use global variable $table_prefix to differ whether sometimes on Wordpress or WPMU. I want this global for my wordpress plugin. But can there be much better method to check whether your pluggin is focusing on wordpress or wpmu ?

any suggestion is going to be great

In WPMU a worldwide variable named wpmu_version ought to be set.

for my inspections I personally use a function I discovered

// from http://frumph.net/wordpress/wordpress-plugin-theme-check-for-multisitewpmu/
        // check for multisite. Returns boolean
        function check_this_is_multsite() {
            global $wpmu_version;
            if (function_exists('is_multisite')){
                if (is_multisite()) {
                    return true;
                }
                if (!empty($wpmu_version)){
                    return true;
                }
            }
            return false;
        }

utilize it such as this

if(check_this_is_multsite()){
    // is on wpmu
} else {
    // is on single
}

You can define a continuing:

e.g.

define('ENVIRONMENT', 'WP');

define('ENVIRONMENT', 'WPMU');