i've installed Apache 2.2.x however when i switched to instal PHP V5.2.17 i did not discover the apache 2.2.x radio button within the web server setup step !! just the fast CGI,other CGI and do not use a web server radio buttons is showing up, things i can perform ??

I suspect you are speaking about home windows. Arranging an effective build of apache, php module, etc is a little of the discomfort, so unless of course it's for production, I would recommend using WampServer or XAMPP.

Otherwise, the PHP modules are here if you want to roll your personal. Make sure to match the PHP and Apache runtimes and word-size (32 or 64 bit).