Once more, I have trouble with my apache virtual host configuration. (The default configuration can be used rather than my specific one).

The issue is not necessarily the misconfiguration but exactly how to resolve it.

Does anybody has good advices to complete resolve this type of problem rapidly?

More informations.

The default conf file is that one:

NameVirtualHost *
<VirtualHost *>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

And also the virtual host config that does not apply is that one:

<VirtualHost *:*>

ProxyPreserveHost On
ProxyPass / http://ip.ip.ip.ip:8088/
ProxyPassReverse / http://ip.ip.ip.ip:8088/
ServerName wiki.mydomain.com

</VirtualHost>

First take a look at config files for syntax errors with apachectl configtest after which consider apache error logs.

I'd this issue too. I discovered it hard to find out, in which the error was happening, when my demands did not hit the expected virtual host.

Put this to your index-page of the default virtual host:

<pre>
<?php print_r($_SERVER); ?>
</pre>

Pay special towards the following values - if they're wrong that could be the reason why you aren't striking the right virtual host:

[HTTP_HOST] => example.com
[HTTP_X_REAL_IP] => 127.0.0.1
[HTTP_X_FORWARDED_FOR] => 127.0.0.1