I'm attempting to upload spree application on ec2.

So as for several pages like admin &lifier checkout to operate, spree has SSL pre build within the jewel.

So, I must modify my apache server configurations in ways it should accept https demands.

Items in virtual host

$ sudo mire /etc/apache2/sites-available/capi_application

<VirtualHost *:443>
 ServerName www.passionate4.net
 DocumentRoot /var/www/capi_app/current/public
 RailsEnv production

 <Directory /var/www/capi_app/current/public>
  Allow from all           
  Options FollowSymlinks MultiViews
 </Directory>
  RequestHeader set X_FORWARDED_PROTO 'https'
</VirtualHost>

sudo mire /etc/apache2/sites-enabled/capi_application

<VirtualHost *:443>
 ServerName www.passionate4.net
 DocumentRoot /var/www/capi_app/current/public
 RailsEnv production

 <Directory /var/www/capi_app/current/public>
  Allow from all           
  Options FollowSymlinks MultiViews
 </Directory>
  RequestHeader set X_FORWARDED_PROTO 'https'
</VirtualHost>

however when i actually do restart I recieve a mistake message:

ubuntu@ip-10-166-185-18:~$ sudo /etc/init.d/apache2 restart
Syntax error on line 10 of /etc/apache2/sites-enabled/capi_app:
Invalid command 'RequestHeader', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

FYI: I've placed following inside

ubuntu@ip-10-166-185-18:/etc/apache2$ cat httpd.conf 
Listen 80 
Listen 443

Problem: Whenever I attempt to gain access to https://passionate4.net/ there is nothing displayed.