I wish to install htmldoc on wamp. My environnment is apache 2.2, php5.3, home windows XP. I adopted the instructions on htmldoc website but it doesn't work, I believe I skipped something that's apparent and for that reason not stated within the doc.

I adopted these instructions : http://www.easysw.com/htmldoc/docfiles/5-cgi.html#6_3_3

That is what Used to do : downloaded htmldoc executable (msi) and installed it in C:wampbinapacheApache2.2.17cgi-bin. As I am on home windows, I do not think I'm able to do symlink and so i place it directly here. I performed htmldoc.exe, which opened up briefly a home windows and closed it (I supposed it authored the secrets within the registry).

I Quickly opened up httpd.conf and added AcceptPathInfo On anywhere (really soon after LoadModule part). I am quite sure you no longer need, however i added AddHandler cgi-script .cgi too, as well as in my alias, I added Options +ExecCGI.

I Quickly restarted Wamp.

After I execute my php code, the pdf is produced but it's empty. I'd exactly the same factor before I attempted to set up htmldoc.

I am quite sure the php code is guaranteed as it creates another (linux) server.

Can there be something I must install ? (cgi, pear maybe ?) Has anybody found a fix for your problem ?

Appreciate your help,

Mariek

EDIT : the command used is :

system("exec htmldoc -t pdf --quiet --webpage $options '$filename' > pdf/myfile.pdf");
header("Location: pdf/myfile.pdf");

and Apache error log shows : professional isn't acknowledged as an intern command...

During my path atmosphere I've C:wampbinphpphp5.3.5C:wampbinapacheApache2.2.17cgi-bin