Ok, this ought to be simple, but I am getting a reasonable quantity of challenge with it. Essentially, I am attempting to rewrite http://server.com/ to http://server.com/homepage, however i only would like it to rewrite it internally--the consumer should not begin to see the /homepage URL. I attempted this:

RewriteRule ^$ /homepage [L]

Also it correctly matches the URL, however it issues a 301 redirect rather than just handling it internally--the consumer is rerouted to http://server.com/homepage. How do you change that?

I seem like this really is something really quite simple, and I am completely missing it, so hopefully someone available might help!

Presuming homepage is really a directory, do this rather:

RewriteRule ^$ /homepage/

I forget exactly what's at play here, so hopefully that'll repair the problem (it really works for me personally), then I'll update my answer by having an explanation of what's happening, with regard to completeness.

Edit: Ah right, it's [cde] and it is mod_dir option attempting to cleanup the URL's missing trailing slash. Without having the trailing slash, the DirectorySlash handler is not invoked, and also, since DirectoryIndex just rewrites the URL before processing happens and mod_rewrite is, automatically, set to DirectorySlash, On works a redirect towards the slash-completed URL.