I'd b .htaccess file doing a simple rewrite from the page names. This is actually the items in the file:

Options +FollowSymlinks
RewriteEngine on
RewriteRule setup setup.php [NC]

I would now like to stop spinning setup to create.perl - how do you do that? I have attempted getting rid of the road in the file, I have attempted removing the file and restarting apache, which is still spinning setup to create.perl. How do you allow it to be stop? It appears to become completely disregarding every other .htaccess file I create, and there is nothing being written towards the error log. Could it be caching the file somewhere? How do you stop it?

I am using apache2 on ubuntu.

However , MultiViews is enabled. MultiViews instantly adds extensions to the asked for Web addresses, if at all possible. It has nothing related to your RewriteRule it so happens that you simply were spinning setup to setup.php so MultiViews as well as your rule used to do exactly the same factor. Add -MultiViews towards the Options directive to disable it.

The solutions is, to spread out the file /etc/apache2/sites-available/default and alter this:

    <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>

Into this:

    <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
    </Directory>

Note the AllowOverride directive - this file apparently overrides other instructions elsewhere.