Ok, so I am unsure how you can even start asking this but here goes...

I presently have wordpress installed for the site - I am attempting to perform a simple php redirect for the site for incoming mobile browsers to become rerouted to the mobile site... However, after i place the script in, nothing happens, no redirect, the website just functions normal.

We now have 3 other Wordpress installs (as vhosts on a single server) and that i could possibly get the redirect focusing on the rest of the installs, simply not the main one we would like it to focus on (obviously), the only real glaring variations would be the htaccess files. I am no htaccess master, so my only thought is the fact that something within the htaccess file is stopping my php redirect, is possible?

Or are there more options that I am missing?

Thanks ahead of time!

Edit, Sorry I didn't remember to include the htaccess file!

RewriteEngine On


# BEGIN W3 Total Cache
<IfModule mod_setenvif.c>
SetEnvIfNoCase Accept-Encoding (gzip|deflate) APPEND_EXT=.$1
</IfModule>
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_URI} \/$
RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-  (app|cron|login|register).php|wp-.*\.php|index\.php) [OR]
RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
RewriteCond %{REQUEST_METHOD} !=POST
RewriteCond %{QUERY_STRING} =""
RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
RewriteCond %{HTTP_USER_AGENT} !(bot|ia_archive|slurp|crawl|spider) [NC]
RewriteCond /var/www/wordpress/wp-content/w3tc/pgcache/$1/_default_.html%{ENV:APPEND_EXT} -f
RewriteRule (.*) wp-content/w3tc/pgcache/$1/_default_.html%{ENV:APPEND_EXT} [L]
</IfModule>
# END W3 Total Cache

# Performance Options
Header unset Pragma
FileETag None
Header unset ETag

# 1 YEAR
<FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|swf|mp3|mp4)$">
Header set Cache-Control "public"
Header set Expires "Thu, 18 Apr 2011 20:00:00 GMT"
Header unset Last-Modified
</FilesMatch>

# 2 HOURS
<FilesMatch "\.(html|htm|xml|txt|xsl)$">
Header set Cache-Control "max-age=7200, must-revalidate"
</FilesMatch>

# CACHED FOREVER
# MOD_REWRITE TO RENAME EVERY CHANGE
<FilesMatch "\.(js|css)$">
Header set Cache-Control "public"
Header set Expires "Thu, 15 Apr 2019 20:00:00 GMT"
Header unset Last-Modified
</FilesMatch>


AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css application/x-    javascript

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !.*.(?:gif|jpg|png|pdf|mp3|avi|mpeg|bmp|mov|ico)

RewriteRule . /index.php [L]
</IfModule>

# END WordPress

# protect the htaccess file
<files .htaccess>
order allow,deny
deny from all
</files>

# protect wpconfig.php
<files wp-config.php>
order allow,deny
deny from all
</files>

# Error Document
ErrorDocument 403 /error/403/index.html

# deny directory listings
Options -Indexes

I really solved this by myself and that i was far to in excess of thinking the problem and didn't remember to determine the more apparent things first. Appears the cache wordpress plugin I had been using was preventing the redirect also it required me 72 hours before it finally dawned on me that caching would prevent a redirect.