I have to create a joomla component however i got confused on determining which version is the greatest to begin with. Using the 6 several weeks release cycle the joomla team has adopted 1.5.25 may be the Current LTS.

Could it be smart to build up mainly for that STS versions?

Basically develop for that current STS will I must port the code to another release given short release cycle?

I believe your most significant question ought to be, on which version of Joomla! are the clients or customers? Could they be using Joomla! 1.5.x for stability, or because other extensions on their own site are restricted to Joomla! 1.5? You need to support Joomla versions dating back to your clients require, which most likely means 1.5.x.

The next question ought to be, exactly what does the roadmap appears like? Here's The new Joomla versions roadmap (iJoomla.com), and here is a chart visualisation "Understanding the Joomla roadmap" (joomlablogger.internet). Joomla 1.6 is really a walking stone to at least one.7, 1.7 is really a walking stone to two.5, 2.5 would be the next lengthy-term support version, and Joomla 2.5 just went Beta2 and will also be generally release soon. You need to support the way forward for Joomla!, which means Joomla 2.5, with 1.7 and perhaps 1.6 too.

There is nothing which states your extension may go with just one version of Joomla!. The popular extension, Community Builder, supports Joomla 1.7, 1.6, 1.5 and 1.0, and Mambo 4.5.0 - 4.6.5. It's more try to have alternate versions of code focusing on different versions from the APIs, however it allows more and more people make use of your component.

As @Jim DeLaHunt stated your subscriber base should help guide to you but consider the next:

  1. STS versions 1.6 &lifier 1.7 are for those intents and reasons just like 2.5 within an API sense while 1.5 is a reasonably step backwards.
  2. 1.5 is effectively EOL (aside from security exploits which may be supported until 3.)
  3. The packaging of just one.5 with 1.6/7/2.5 version leaves a great deal to be preferred.
  4. 1.5 operates on PHP 4.3.10 and MySQL 4.1.x
  5. The length of time have you got? Supporting 2 versions will clearly consume additional time.