I installed WordPress on EC2, situated in /var/www/html/wordpress. I adopted the WordPress help guide to copy index.php and .htaccess to root that is /var/www/html, and modified index.php and establishing admin panel. It really works pretty much basically stay with only default link, for example: http://www.cubcanfly.com/?p=5, however other permalink options fails, really all the permalink options.

My .htaccess is

# BEGIN WordPress
<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
</IfModule>

in /etc/httpd/conf/httpd.conf

LoadModule rewrite_module modules/mod_rewrite.so

isn't said.

Thanks ahead of time

Take a look only at that publish How does RewriteBase work in .htaccess

You have to change RewriteBase / to RewriteBase /wordpress

Finally I've found the issue. It is the AllowOverride option in httpd.conf that is situated in /etc/httpd/conf/httpd.conf, "sudo find / -title httpd.conf -print" can certainly think it is. I transformed any AllowOverride NONE->ALL where i'm able to get in the file. It simply labored,even without having done any switch to .htaccess

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
</IfModule>

This .htaccess creates my host by which wordpress is set up in its very own directory.

Thanks @adlawson @Will, without you, I could not discover the problem.

http://codex.wordpress.org/Using_Permalinks this official guide is very enough to make use of permalink even wordpress is set up in a sub directory.