I've pressed my .htaccess files towards the production severs, but they are not effective. Would a restart be the next phase, or must i check another thing.


In the apache documentation: Most generally, the issue is that AllowOverride isn't set so that your configuration directives are now being honored. Make certain you don't possess a AllowOverride None essentially for that file scope under consideration. A great test with this would be to put garbage inside your .htaccess file and reload. If your server error isn't produced, then you probably have AllowOverride None essentially.

A restart is not needed for changes to .htaccess. Another thing is wrong.

Make certain your .htaccess includes the statement

RewriteEngine on

that is needed even when it is also contained in httpd.conf. Also make sure that .htaccess is readable through the httpd process.
Look into the error_log - it will explain associated with a errors inshtaccess if it's getting used. Putting an intentional syntax error inshtaccess is a great check to make certain the file has been used -- you need to get a 500 error on any page within the same directory.

Lastly, you are able to enable a rewrite log using instructions such as the following inside your httpd.conf:

RewriteLog "logs/rewritelog"

RewriteLogLevel 7

The log file thus produced provides you with the gory detail which rewrite rules matched up and just how these were handled.

What's inside your .htaccess? RewriteRules? Make sure that mod_rewrite is installed and enabled.

Other things? Try setting AllowOverride to 'all' on that directory.

only when you haven't added the mod re-write module to apache.

you only have to restart apache should you change any apache ".conf" files

I have a similar problem also it appears PiedPiper publish about AllowOverride were most useful. Look at your httpd.conf apply for "AllowOverride" and make certain it's set to any or all.