There is Codeigniter on Ubuntu 10 (Light). I've an htaccess file:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /dort
#Removes access to the system folder by users.
#Additionally this will allow you to create a System.php
#controller, previously this would not have been possible.
#'system' can be replaced if you have renamed your system folder.
RewriteCond %{REQUEST_URI} ^system.*
RewriteRule ^(.*)$ /dort/index.php?/$1 [L]
#Checks to see if the user is attempting to access a valid file,
#such as an image or css document, if this isn't true it sends
#the request to index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /dort/index.php?/$1 [L]
</IfModule>
<IfModule !mod_rewrite.c>
# If we don't have mod_rewrite installed, all 404's
# can be sent to index.php, and everything works as normal.
# Submitted by: ElliotHaughin
ErrorDocument 404 /index.php
</IfModule>

Until recently, we connected the remote server by having an Ip,my base website is sitting within folder known as ‘dort’, therefore we accustomed to refer to it as such as this: http://some_ip/dort

now we planned an online host to dort, so it is called like: http://demo.dort.com/ and all of a sudden nothing

works aside from the login page (index.php). I’ve transformed $config[‘base_url’] in config.php however i

keep getting 404.

Help :(

would you use virtual host?

i've same issue and that i solve with this particular

1)make virtual host during my situation is much like this: file /etc/apache2/sites-available/default

<VirtualHost *:80>
    ServerAdmin admin@email.com
    DocumentRoot /var/www/dort
    ServerName yourdomain.biz #this domain must be define tld info.
    ErrorLog /var/log/apache2/error_2.log
    <Directory /var/www/dort>
        Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
                # Uncomment this directive is you want to see apache2's
                # default start page (in /apache2-default) when you go to /
                #RedirectMatch ^/$ /apache2-default/

    </Directory>

</VirtualHost>

2.setting host in file /etc/hosts

127.0.0.1   localhost
127.0.0.1   yourdomain.biz

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

4.htacces

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

    # Send admin URL's to the admin controller (then skips the rest of the redirect rules)
    RewriteCond %{REQUEST_URI} ^/admin(.*)
    RewriteRule ^(.*)$ /index.php/admin/$1 [L]    

    # Redirects any request thats not a file or directory through to the main controller
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ /index.php/main/$1 [L]

</IfModule>

<IfModule !mod_rewrite.c>
    # If we don't have mod_rewrite installed, all 404's
    # can be sent to index.php, and everything works as normal.
    # Submitted by: ElliotHaughin

    ErrorDocument 404 /index.php
</IfModule> 

3.make certain when restart apache not show error

 Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

4.visit browse and run this url http://yourdomain.biz