I lately installed Joomla 1.6 on my small XAMPP local server and that i got this error message:

Strict Standards: Promise of JButtonPopup::fetchId() ought to be suitable for those of JButton::fetchId() in J:XAMPPhtdocsjoomla16librariesjoomlahtmltoolbarbuttonpopup.php online 78

I attempted with XAMPP 1.73 and 1.74 and that i obtain the same message, so when I attempt to set up any extension, I recieve the "can't create directory" message.

Help me.

You have to improve your php.ini file.

Search for:

error_reporting = E_ALL | E_STRICT

And replace:

error_reporting = E_ALL & ~E_STRICT

Search for:

display_errors = On

And replace:

display_errors = Off

Make certain that you simply fine every instance it's possible for individuals to look more often than once within the file.

I installed Joomla 1.6 with Gantry framework on EasyPHP 5.3.6 and also have the same problems. I possibly could avoid these error messages setting the "display_errors" configuration to "Off" in EasyPHP configuration. It really works for now.