AFter moving a joomla 1.5 site to Drupal 6 by utilizing Joomla to Drupal module. While posting I ticked full HTML. Now a few of the pages have are annoying codes as proven below:

<!--[if gte mso 9]>

Normal
0
21

false
false
false

TR
X-NONE
X-NONE

MicrosoftInternetExplorer4


<![endif]--><!--[if gte mso 9]>

DefSemiHidden="true" DefQFormat="false" DefPriority="99"
LatentStyleCount="267">

UnhideWhenUsed="false" QFormat="true" Name="Normal"/>

UnhideWhenUsed="false" QFormat="true" Name="heading 1"/>

I believe they're replicated and copied and pasted from MS Word. How could I fix these? Thanks

I'm able to think about 2 options:

  1. Try re-posting with 'filtered html', this can strip non-approved tags (strained html could be customised to permit certain tags e.g. <img>). I'm not sure when the import module includes a setting to select this or otherwise.
  2. Make use of a wealthy text editor on drupal, and by hand edit each node. I understand the WYSIWYG editor ckeditor includes a config parameter to pressure pasting in to the textbox to become plain text