I have needed to range from testing around the live server, to testing in your area on the virtual apache server. I have installed XAMPP all right, downloaded and installed the wordpress files and also the database. Everything looks great! The neighborhood version of my home page is similar towards the live version. There's just one problem: the home page may be the only page that actually works. After I click among the links i.e. the "about" page (http://localhost/wordpress/about/), I'm rerouted towards the xampp user interface (http://localhost/xampp).

I've got a good feeling it has related to an issue with the "pretty links"/mod_rewrite rules. I ensured I introduced within the .htaccess file, also it consists of the rewrite instructions. The wordpress database has got the proper permalink structure, and also the httpd.conf file has got the "RewriteEngine on" and also the "FollowSymLinks" directives enabled. There has to be some kind of rewrite problem here, although I'm not ruling out another thing stupid I would did. Thanks for your help!

-E

*Here's what the .htaccess appears like:

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteCond % !-f
RewriteCond % !-d
RewriteRule . /index.php [L]

# Finish WordPress

Within the httpd.conf, alter the

DocumentRoot "/path/to/your/app/wordpress"

also

# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/path/to/your/app/wordpress">

This will work, the road is absolute.

And have you got load the:

LoadModule rewrite_module modules/mod_rewrite.so

in httpd.conf??

In case your server version works together with a website title, i.e: http://domainname.com is equivalent that http://localhost/wordpress the rewrite rules is going to be differents. publish the guidelines here.