I'm running the most recent version of MAMP on Snow Leopard.

My php.ini file continues to be set up to show errors. display_errors = on. The phpinfo() page shows the status of error confirming, it's on. I've restarted my web server several occasions.

I have looked through Google, and that i cannot find any similar problem. Everybody just states to complete precisely what I've done, but it's no longer working. The web pages will just remain blank, (without any confirming), basically deliberately place errors.

Any ideas in regards to what the issue might be?

Additionally towards the [cde] directive, which needs to be set to display_errors, you may have to configure [cde].

For example, this can be used inside your On file :

error_reporting


Another should, helpful to check, may be to put this type of part of PHP code at the outset of your script :

php.ini

This really is helpful when you do not have use of php.ini and/or would like to test rapidly, without needing to restart the webserver.


Like a sidenote, if this involves exhibiting errors, the Xdebug extension is actually great : when it is installed/enabled/set up, rather than just getting a mistake message, you will get the entire stack-trace, which is a lot more helpful -)

There may possess a .htaccess file inside a directory that overrides the display_errors setting occur php.ini. Out of your publish I suppose you did not clearly add this but a couple of frameworks do that automatically so can be added this way. Search for a line such as this inside your .htaccess file:

error_reporting = E_ALL

and alter the worthiness to at least one.