I'm a newbie and that i setup Mamp and virtualhostx on my small IMAC and delay pills work fine except after i restart the server in virtualhostx it informs me multiple servers are running also it might cause conflicts. I'm able to get into configurations and switch off Apache however it begins again after i restart with virtualhostx.

I made use of the setup recommended in http://seansperte.com/entry/Setting_Up_a_Killer_Local_Web_Development_Environment_on_a_Mac_with_MAMP_an/

and hang my Apache and Mysql ports to to 80 and 3306 correspondingly

How do i keep your built-in Apache switched off?

You are able to disable it in System Preferences > Discussing. Take away the check alongside "Web Discussing".