I am running mod_mono 2.4.4 on Ubuntu and I am discovering that I have needed to undergo my VB files and add "imports System.Configuration" to these to solve the title error. It was not essential in mod_aspdotnet around the Home windows side.

 I have, however, run into one error of which I can't find the source:


    System.Web.Compilation.CompilationException: VBNC30451: Could not resolve the name 'ConfigurationManager'
  at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath, System.CodeDom.Compiler.CompilerParameters options) [0x00000] 
  at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath) [0x00000] 
  at System.Web.Compilation.BuildManager.GenerateAssembly (System.Web.Compilation.AssemblyBuilder abuilder, System.Collections.Generic.List`1 buildItems, System.Web.VirtualPath virtualPath, BuildKind buildKind) [0x00000] 
  at System.Web.Compilation.BuildManager.BuildAssembly (System.Web.VirtualPath virtualPath) [0x00000] 

Is the effect of a skipped step or incorrect configuration that I must keep adding this import?

Somewhere, most likely /etc/mono/2./web.config, there is a default configuration file. Verify it consists of something similar to this:

             <pages>
                    <namespaces>
                            <add namespace="System" />
                            <add namespace="System.Collections" />
                            <add namespace="System.Collections.Specialized" />
                            <add namespace="System.Configuration" />
                            <add namespace="System.Text" />
                            <add namespace="System.Text.RegularExpressions" />
                            <add namespace="System.Web" />
                            <add namespace="System.Web.Caching" />
                            <add namespace="System.Web.SessionState" />
                            <add namespace="System.Web.Security" />
                            <add namespace="System.Web.Profile" />
                            <add namespace="System.Web.UI" />
                            <add namespace="System.Web.UI.WebControls" />
                            <!-- <add namespace="System.Web.UI.WebControls.WebParts" /> -->
                            <add namespace="System.Web.UI.HtmlControls" />
                    </namespaces>
            </pages>

The default. Which should take proper care of adding the default imports.

Btw, mod_mono 2.4.4 is a little old nowadays. Try getting more recent packages.