I've requested our host company to include mod_python to the httpd server. The server seems to stay in an hsphere cluster plus they seem to use yummy to manage it. He's confirming some dependencies missing and that i do't quite know how that may came about.

versions (this is because almost as much ast I've been given): CentOS 5 apache - 2 (but he isn't sure concerning the exact version) mod_python - 3.3.1 numpy - 1.1.1 scipy - .6. yummy - 3.2.8 hsphere - 3.1 patch 1

The mistake he's confirming is the following:

yum install mod_python
...
Package mod_python.i386 0:3.2.8-3.1 set to be updated
Processing Dependency: httpd >- 2.0.40 for package: mod_python
Processing Dependency: httpd-mmn = 20051115 for package: mod_python
Finished Dependency Resolution
Error: Missing Dependency: httpd >= 2.0.40 is needed by package mod_python
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_python

Not a UNIX admin I have only a naive guess relating to this, however the message would appear to point out that there's a version mismatch between httpd and mod_python as opposed to the dependencies being missing completely.

So my real question is, what must i request/tell the Administrator to complete?

Can there be something clearly wrong using the mixture of components above?

We've mod_python 3.3 running on Apache 2.2 on the CentOS (didn't remember the version). All we did is download the tar.gz (from http://httpd.apache.org/modules/python-download.cgi) , extract it...

$ ./configure --with-apxs=/usr/local/apache2/bin/apxs
$ ./make
$ su
$ make install

Everything works fine. We could not use yummy so things are constructed from source. My suggestion is always to attempt to build from source.

My first reaction is always to yum update apache (or simply a yum update).

Then try the yum install mod_python.

also getting same problem

--> Running transaction check ---> Package mod_python.i386 :3.2.8-3.1 set to become up-to-date --> Processing Dependency: httpd >= 2..40 for package: mod_python --> Processing Dependency: httpd-mmn = 20051115 for package: mod_python --> Finished Dependency Resolution Error: Missing Dependency: httpd >= 2..40 is required by package mod_python Error: Missing Dependency: httpd-mmn = 20051115 is required by package mod_python