I installed redmine around the apache and used mod_ruby first, that was incredible slow... now i switched to phusion passenger however the response time continues to be really slow ( speaking about 5-6 seconds here, even utilizing a wget to localhost in the server itself.. )

i simply removed the "old" mods in the apache dir, but it is still slow... anyway, the logfile a minimum of shows, the passenger can be used:

127.0.0.1 - - [15/Nov/2009:10:38:25 +0000] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9
(Debian) Phusion_Passenger/2.2.5 PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 
OpenSSL/0.9.8g mod_perl/2.0.4 Perl/v5.10.0 (internal dummy connection)"

I've no clue why this occurs, the server ought to be fast enough.. apache-log is not showing anything suspicious..

EDIT:

Just hint.. The "passenger-status" is "empty":

----------- General information -----------
max      = 6
count    = 0
active   = 0
inactive = 0
Waiting on global queue: 0

Any advice? Thanks!

Try growing the PoolIdleTime setting (that is 2 Minutes automatically I believe). Setting it to assisted speed the startup of my Redmine stack a great deal. Take a look at this question on Serverfault which values to create.

You should use the config option PassengerMinInstances, avaliable since Passenger 3... This setting enables you to definitely tell Apache the number of cases of your deployment must stay alive, even if your programs happen to be idle for any logner period compared to based on PoolIdleTime. Take a look in the Phusion Passenger docs. You will find some otrher helpfull choices to enhance your deoployment's performance.

This answer might be a little outdated --I am quite sure almost everybody be aware of additional features of Passenger, however i wasn't, which question assisted a great deal.