I have got mydomain.com

*.conf folder consists of a couple of .conf files for subdomains plus some virtual domain names for example myotherdomain.com

I would like all demands to http mydomain.com to obtain rerouted to https mydomain.com

And So I have this:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

That actually works, but http myotherdomain.com will get rerouted to https myotherdomain.com Let me keep myotherdomain.com not get rerouted to https.

So with the help of stackoverflow yesterday, I transformed my file to:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteCond %{HTTP_HOST} !myotherdomain\.com
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

The present sites all work all right. The issue I've now's that http myotherdomain.com does not get offered correctly -- it's as if it's disregarding myotherdomain.conf:

<VirtualHost *:80>
    DocumentRoot /home/webadmin/myotherdomain.com/html
    ServerName myotherdomain.com
    ServerAlias "www.myotherdomain.com"
    <Directory /home/webadmin/myotherdomain.com/html>
            Options Includes FollowSymLinks
            AllowOverride All
    </Directory>
</VirtualHost>

Ideas?

apachectl- S returns:

VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:443        is a NameVirtualHost
    default server mydomain.com (/etc/httpd/conf/httpd.conf:1100)
    port 443 namevhost mydomain.com (/etc/httpd/conf/httpd.conf:1100)
    port 443 namevhost mydomain.com (/etc/httpd/conf.d/drupal.conf:3)
    port 443 namevhost mydomain.com (/etc/httpd/conf.d/openid.conf:1)
    port 443 namevhost mydomain.com (/etc/httpd/conf.d/ssl.conf:88)

*:80         is a NameVirtualHost
    default server mydomain.com (/etc/httpd/conf/httpd.conf:1084)
    port 80 namevhost mydomain.com (/etc/httpd/conf/httpd.conf:1084)
    port 80 namevhost myotherdomain.com (/etc/httpd/conf.d/myotherdomain.conf:1)

Syntax OK

I am certain I'm missing something super fundamental here...