i run wordpress on nginx, after i publish a comment for my publish, i recieve this error "504 Gateway Timeout" with nginx, can anybody let me know how you can eliminate this error? Thanks!

Presuming you are using fastcgi:

It has been clarified before within the following question:

http://stackoverflow.com/questions/561946/how-do-i-prevent-a-gateway-timeout-with-nginx

In a nutshell Browse the configuration option 'fastcgi_read_timeout'.

Rapidly you have to navigate about this links

begin to see the similar or duplicate stacks on following links

  1. Django site on Nginx+FastCGI goes (504 gateway timeout)
  2. How do you prevent a Gateway Timeout with Nginx
  3. Drupal + Nginx + Php-cgi : 502 Bad Gateway error