I am looking to get Rails happening Rackspace Servers and, regrettably, they do not do support for Rails. I'm using Apache and Passenger (no RVM) on Ubuntu. After I hit the server, I acquired the next error:

no such file to load -- bundler/setup

The traceback is the following:

/usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in gem_original_require' /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 inrequire' /rails/gradebook-attendance/config/boot.rb 6
/usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in gem_original_require' /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 inrequire' /rails/gradebook-attendance/config/application.rb 1
/usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in gem_original_require' /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 inrequire' /rails/gradebook-attendance/config/atmosphere.rb 2
/usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in gem_original_require' /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 inrequire' config.ru 3
/usr/lib/ruby/1.8/rack/builder.rb 46 in instance_eval' /usr/lib/ruby/1.8/rack/builder.rb 46 ininitialize' config.ru 1 in `new' config.ru 1

Bundler is certainly installed. After I execute jewel list -d bundler, I recieve back

* LOCAL GEMS *

bundler (1..17) Authors: André Arko, Terence Lee, Carl Lerche, Yehuda Katz Rubyforge: http://rubyforge.org/projects/bundler Home page: http://gembundler.com Installed at: /opt/ruby/lib/ruby/gems/1.8 The easiest method to manage your application's dependencies

Also, running irb and typing "require 'bundler'" returns true.

$Jewel_HOME indicates a path which includes the bundler-1..17 jewel.

I've also set RUBYOPT=rubygems

Any assistance is appreciated!

Have you got Jewel_HOME occur your user space or are you currently while using SetEnv directive for apache. For those who have it occur something similar to your party profile, then apache wont observe that env variable. Inside your vhost you might want to add something similar to:

SetEnv GEM_HOME /opt/ruby/lib/ruby/gems/1.8