The issue is within the question. I have done an intensive analysis for solutions when it comes to this and that i know you will find subjects for this and I have adopted them as well and absolutely nothing has labored. That being stated I'll list out exactly everything I have done to date. I'm running PHP 5.2.14 with Zend Debugging around the latest Eclipse version on my small Home windows XP computer. I've got a 1 GB of RAM. I've XAMPP running with Apache, MySQL, and FileZilla installed.

On XAMMP I have done the next (Apache was off throughout these changes): Clicked on on Admin in the XAMMP User Interface and visited https:// localhost/xampp/. After that I recognized the certs out of this line around the welcome page: "For OpenSSL support please make use of the test certificate with https:// 127...1 or https:// localhost." On that same section I checked phpinfo(). Under Atmosphere, SERVER["HTTPS"] is on. Under Apache Atmosphere, HTTPS is On. Under PHP Variables, _SERVER["HTTPS"] is On. Under Phar, OpenSSL support is disabled (install ext/openssl). I'm not sure how you can let the Phar one.

Now concerning the files themselves in C:xampp, I have visited the php folder. Under both production and development php.ini files (better safe than sorry), I've allow_url_fopen=On, allow_url_include=On, and that i removed the semi-colon to ensure that extension=php_openssl.dll is no more said out. I even confirmed the .dll is incorporated in the ext folder from the php folder. Both libeay32.dll and ssleay32.dll have been in the php and apache folders. The apache folder does not contain either push or dev php.ini files.

I have visited http://www.slproweb.com/products/Win32OpenSSL.html and installed Win32 OpenSSL v1..0d for safe measure.

The type of code under consideration during my retrieve_website.php could be this:

$urlquery = "https://www.googleapis.com/customsearch/v1?key=".$appid."&cx=".$google_searchid."&q=".$query."&alt=atom&num=".$results;
$xmlresults = file_get_contents($urlquery);

I've two other websites which i query but they're http plus they labored fine. I additionally have this type of code joined close to the finish from the script:

echo 'openssl: ',  extension_loaded  ('openssl') ? 'yes':'no', "\n";
echo 'http wrapper: ', in_array('http', $w) ? 'yes':'no', "\n";
echo 'https wrapper: ', in_array('https', $w) ? 'yes':'no', "\n";
echo 'wrappers: ', var_dump($w);

After I run it as being a PHP Script on Eclipse, everything results perfectly fine generate an income want together with these results:

openssl: yes
http wrapper: yes
https wrapper: yes
wrappers: array(10) {
  [0]=>
  string(5) "https"
  [1]=>
  string(4) "ftps"
  [2]=>
  string(3) "php"
  [3]=>
  string(4) "file"
  [4]=>
  string(4) "data"
  [5]=>
  string(4) "http"
  [6]=>
  string(3) "ftp"
  [7]=>
  string(13) "compress.zlib"
  [8]=>
  string(14) "compress.bzip2"
  [9]=>
  string(3) "zip"
}

Despite each one of these changes I have made (once i cranked up Apache), I get exactly the same errors as the very first time after i run my php file as PHP Web Site on Eclipse as well as on Opera as http:// localhost/tutorial/retrieve_website.php:

Warning: file_get_contents() [function.file-get-contents]: Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in C:\xampp\htdocs\tutorial\retrieve_website.php on line 29

Warning: file_get_contents(https:// www.googleapis.com/customsearch/v1?key=*removed API ID*&cx=*removed search ID*&q=The+Devil+went+down+to+Georgia&alt=atom&num=5) [function.file-get-contents]: failed to open stream: No such file or directory in C:\xampp\htdocs\tutorial\retrieve_website.php on line 29

Warning: DOMDocument::loadXML() [domdocument.loadxml]: Empty string supplied as input in C:\xampp\htdocs\tutorial\retrieve_website.php on line 33
openssl: no http wrapper: yes https wrapper: no wrappers: array(10) { [0]=> string(3) "php" [1]=> string(4) "file" [2]=> string(4) "glob" [3]=> string(4) "data" [4]=> string(4) "http" [5]=> string(3) "ftp" [6]=> string(3) "zip" [7]=> string(13) "compress.zlib" [8]=> string(14) "compress.bzip2" [9]=> string(4) "phar" } 

What exactly is it which i have overlooked or unsuccessful to complete? To my very own understanding, I have done exactly what I have investigated about concerning https and openssl