I am attempting to use a sqlite3 database for my Django setup on my small computer but can't appears to obtain this working. I've below.

DATABASES = {
'default': {
    'ENGINE': 'sqlite3', # Add 'postgresql_psycopg2', 'postgresql', 'mysql', 'sqlite3' or 'oracle'.
    'NAME': 'C:\Python27\Lib\site-packages\django\bin\cms\cms.db',                      # Or path to database file if using sqlite3.
    'USER': '',                      # Not used with sqlite3.
    'PASSWORD': '',                  # Not used with sqlite3.
    'HOST': '',                      # Set to empty string for localhost. Not used with sqlite3.
    'PORT': '',                      # Set to empty string for default. Not used with sqlite3.
}

What shall we be held doing wrong? Thanks.

ENGINE must be: django.db.backends.sqlite3

Also, don't use the worldwide site-packages directory for the databases. Have you feel the tutorial? Your database file ought to be within the same directory in which you produced your programs (exactly the same directory, or any subdirectory underneath the same directory where your settings.py file is).

EDIT:

What you ought to do, when your have installed django properly:

  1. Open the command prompt
  2. From every other directory, like say C:\Projects (first, cd into that directory).
  3. Then, type django_admin.exe startproject cms, so that your command ought to be C:\Projects\>django_admin.exe startproject cms
  4. Now you must a directory cms, become it cd cms
  5. Next, edit settings.py (so in C:\Projects\cms>)

Alter the databases dictionary for this:

DATABASES = {
'default': {
    'ENGINE': 'django.db.backends.sqlite3', # Add 'postgresql_psycopg2', 'postgresql', 'mysql', 'sqlite3' or 'oracle'.
    'NAME': 'cms.db',                      # Or path to database file if using sqlite3.
    'USER': '',                      # Not used with sqlite3.
    'PASSWORD': '',                  # Not used with sqlite3.
    'HOST': '',                      # Set to empty string for localhost. Not used with sqlite3.
    'PORT': '',                      # Set to empty string for default. Not used with sqlite3.
}
}

Now run python manage.py syncdb from C:\Projects\cms directory