In SQL Server Management Studio 2008, basically log right into a hosting that is shared provider with lots of databases on a single server, I cannot make use of the Object Explorer. This labored fine in 2005. Anyway to alter this behavior?

It throws this exception:

  • The server principal "myusername" can't access the database "first-database-alphabetically-on-shared-server" underneath the current security context.

click View, Object Explorer Particulars. Then, open Databases. Finally, click on the header posts and uncheck Collation.

Source: http://sqlblog.com/blogs/aaron_bertrand/archive/2008/07/07/a-little-management-studio-oops.aspx

I solved this for my very own machine not long ago and needed to look the problem support. Hopefully this link and also the links after that can help you discover the answer if the does not. It appears familiar as to the i needed to do.