I acquired the mistake:

request failed: URI too long (longer than 8190)

I have seen other posts on StackOverflow for that one. Individuals posts recommend:

  • Not altering Apache configurations (agree)
  • Using publish, not get
  • Not using jsonp with publish

I am using jQuery's AJAX to Publish:

    $.ajax({
        url: "test.php",
        dataType: "json",
        data: paras,
        type: "POST",
        success: function(ret){callback(ret);}
    });

It's my impression you should use json simply not jsonp. Correct? If that's the case, why might I be obtaining the error?

You should attempt setting proccessData to false.

In the paperwork:

Automatically, data passed to the data option being an object (technically, anything apart from a string) is going to be processed and changed right into a query string, fitting towards the default content-type "application/x-www-form-urlencoded". If you wish to send a DOMDocument, or any other non-processed data, set this method to false.

to avoid the data being put into the url:

$.ajax({
    url: "test.php",
    dataType: "application/json",
    data: paras,
    type: "POST",
    proccessData: false, // this is true by default
    success: function(ret){callback(ret);}
});

Honestly, I figured it was automatic, consider your url is simply too lengthy it's worth a go.