I installed Passenger 3..7 (also happens with 3..6) on Ubuntu on EC2.

I can not have it to set up. After I run: RAKE APACHE2

I recieve the mistake: /usr/lib/libldap_r-2.4.so.2: undefined mention of the `sasl_global_listmech@SASL2'

Does anybody know why? Or how you can repair it?

creating libev.la
(cd .libs && rm -f libev.la && ln -s ../libev.la libev.la)
g++ ext/common/LoggingAgent/Main.cpp -o agents/PassengerLoggingAgent -Iext -Iext/common -Iext/libe -I/bitnami/rubystackDev-linux/output/common/include -DHAS_CURL_EASY_RESET  -D_REENTRANT -I/usr/loal/include -DHASH_NAMESPACE="__gnu_cxx" -DHASH_NAMESPACE="__gnu_cxx" -DHASH_FUN_H="<hash_fun.h>" -HAS_SFENCE -DHAS_LFENCE -Wall -g -DPASSENGER_DEBUG -DBOOST_DISABLE_ASSERTS ext/common/libpassengercommon.a ext/common/libboost_oxt.a ext/libev/.libs/libev.a -L/bitnami/rubystackDev-linux/output/comon/lib -lcurl -L/bitnami/rubystackDev-linux/output/common/lib -L/bitnami/rubystackDev-linux/outpu/common/lib -lz -lpthread -rdynamic
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_global_listmech@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_set_mutex@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_encode@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_client_start@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_client_init@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_errdetail@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_version@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_errstring@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_dispose@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_setprop@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_getprop@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_decode@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_client_step@SASL2'
/usr/lib/libldap_r-2.4.so.2: undefined reference to `sasl_client_new@SASL2'
collect2: ld returned 1 exit status
rake aborted!
Command failed with status (1): [g++ ext/common/LoggingAgent/Main.cpp -o ag...]

It may be good to log an problem on http://code.google.com/p/phusion-passenger/issues/list . I'd suggest returning to ~3..2 to see in the event that works.