I simply moved my wordpress blog in one host to a different but permalink is giving trouble. Apart from the home page, other pages provide a page not found error.

I edited the htaccess according to instructions

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /projects/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wdmgroup/index.php [L]
</IfModule>

I even attempted removing the htaccess and spinning but with no success.

P.S : htaccess and Mod Rewriteare both enabled in Apache's conf

Regards, Loveleen

Remove .htaccess and totally reset permalinks from inside Admin at Dashboard>>Settings>>Permalinks to be certain permalinks are occur the database too as with the .htaccess file that Wordpress creates.

Make sure Wordpress is within /wdmgroup/ , because this is where it ought to be situated, based on your .htaccess.

If you are moving Wordpress to root, see Moving WordPress « WordPress Codex.

Based on your .htaccess file, your website ought to be within the http://www.site.com/projects/wdmgroup/ - folder. Could it be so? Also, perhaps you have update needed records within the wp_options table inside your database?

I discovered the answer. Anything else was attempted but nonetheless it didnt work. Later i recognized which i needed to create a Virtual DIrectory in apache for folder wdmgroup that we had directly placed within the www folder.

Look at your apache configuration and verify that for that directory that you store your Wordpress installation you've following configurations enabled (most likely you'll have more configuration choices for the particular directory, but fundamental essentials minimum needed for Wordpress fancy permalinks):

<Directory var/www/>
FollowSymLinks
AllowOverride All
</Directory>