I'm trying to utilize a php contact page on widows asp.internet hosting package, php is enabled but nonetheless my form isn't delivering email it's pointing to error.html page......

this is actually the code

<?php

$EmailFrom = "anksaltlamps.com"

$EmailTo = "support@anksaltlamps.com"

$Subject = "Website Query"

$Title = "Not Specified"

$Tel= "Not Specified"

$City= "Not Specified"

$Country= "Not Specified"

$Other= "Not Specified"

$Address= "Not Specified"

$Message= "Not Specified"

$Condition= "Not Specified"

$Title = Trim(stripslashes($_Publish['Name']))

$Tel = Trim(stripslashes($_Publish['Tel']))

$Email = Trim(stripslashes($_Publish['Email']))

$City = Trim(stripslashes($_Publish['City']))

$Condition = Trim(stripslashes($_Publish['State']))

$Country = Trim(stripslashes($_Publish['Country']))

$Other = Trim(stripslashes($_Publish['Other']))

$Address = Trim(stripslashes($_Publish['Address']))

$Message = Trim(stripslashes($_Publish['Message']))

// prepare email body text

$Body = ""

$Body .= "Title: "

$Body .= $Title

$Body .= "n"

$Body .= "Tel: "

$Body .= $Tel

$Body .= "n"

$Body .= "Email: "

$Body .= $Email

$Body .= "n"

$Body .= "Address: "

$Body .= $Address

$Body .= "n"

$Body .= "City: "

$Body .= $City

$Body .= "n"

$Body .= "Condition/Province: "

$Body .= $Condition

$Body .= "n"

$Body .= "Country: "

$Body .= $Country

$Body .= "n"

$Body .= "Other Country: "

$Body .= $Other

$Body .= "n"

$Body .= "Message: "

$Body .= $Message

$Body .= "n"

ini_set('sendmail_from', 'support@anksaltlamps.com')

// send email

$success = mail($EmailTo, $Subject, $Body, "From: <$EmailFrom>")

// redirect to success page

if ($success)

else

?>

or else you check it on the internet with this link

link text

Look at this. This really is most likely because of your mail configurations in php.ini.