I am a new comer to PHP and also the whole Light stack but I have handled to have it ready to go on my small Ubuntu 10.10 system. Everything appears to become working except for error reposting within the browser that we cannot appear to obtain working (and that we can't work without!).

I have read numerous article along with other threads which indicate the following values ought to be applied within the file /etc/php5/apache2/php.ini:

  • display_errors = On
  • display_startup_errors = On

I have restarted apache2 as well as restarted my computer as well as the existence of me I simply can't have it working. I have even attempted using phpinfo() function which reviews these configurations are as I have set them and so i know it's obtaining the right configuration file but nothing!

Any help could be welcome.

To really make it work you need to cause you to php.ini seem like this:

 display_errors

100 Default Value: On

101 Development Value: On

102  Production Value: Off

103

104  display_startup_errors

105 Default Value: On

106 Development Value: On

107  Production Value: Off

108

109  error_confirming

110 Default Value: E_ALL &lifier ~E_NOTICE

111 Development Value: E_ALL  E_STRICT

112  Production Value: E_ALL &lifier ~E_DEPRECATED

113

114  html_errors

115 Default Value: On

116 Development Value: On

117  Production value: Off

118

119  log_errors

120 Default Value: On

121 Development Value: On

122  Production Value: On

Then restart your apache2 server and everything works fine. Best of luck!

Once you edit /etc/php5/apache2/php.ini make sure to restart apache.

That can be done by running:

sudo service apache2 restart

Take a look at error_confirming directive in php.ini.

Try adding log_errors = Off and appearance the mistake_confirming setting be it set sufficient.