I am using wordpress ajax Calendar future post with wordpress and tipTip to exhibit publish pictures and game titles on mouse hover. I'm able to obtain the wordpress_get_attachment_image_src to obtain the URL after ajax reload, I'm able to obtain the correct thumbnail id though. it uses microAjax. The code with comments describes the problem. I am stuck.

 $ak_post_titles = $wpdb->get_results("SELECT ID, post_title, DAYOFMONTH(post_date) as dom "
        ."FROM $wpdb->posts "
        ."WHERE YEAR(post_date) = '$thisyear' "
        ."AND MONTH(post_date) = '$thismonth' "
       // ."AND post_date < '".current_time('mysql')."' "
        ."AND post_type = 'post' AND  (post_status = 'publish' or post_status='future')"
    );

    if ( $ak_post_titles ) {
        foreach ( (array) $ak_post_titles as $ak_post_title ) {

                $post_title = esc_attr( apply_filters( 'the_title', $ak_post_title->post_title, $ak_post_title->ID ) ); 
        $permalink = get_permalink($ak_post_title->ID);
        $ak_post_thumb_id = get_post_thumbnail_id($ak_post_title->ID); // this works, the ID changes everytime ajax reloads
        $image_url = wp_get_attachment_image_src($ak_post_thumb_id,'htip', false); //this works 'once' before the ajax request it returns false after the request

         $ak_post_thumb = $image_url[0];
                if ( empty($ak_titles_for_day['day_'.$ak_post_title->dom]) )
                    $ak_titles_for_day['day_'.$ak_post_title->dom] = '';
                if ( empty($ak_titles_for_day["$ak_post_title->dom"]) ) // first one
                    $ak_titles_for_day["$ak_post_title->dom"] = "<a href=\" " .$permalink . "\"> <img src=" . $ak_post_thumb . " /> </a>" . "<a class =\"bortitle\" href=\" " .$permalink . "\">" . $post_title . "</a>";
                else
                $ak_titles_for_day["$ak_post_title->dom"] .= $ak_title_separator . "<a href=\" " .$permalink . "\"> <img src=" . $ak_post_thumb . " /> </a>" . "<a class =\"bortitle\" href=\" " .$permalink . "\">" . $post_title . "</a>";
    }
}

The publish thumbnail id works each time, but the one which brings the url appears to fail.