I've got a client having a Wordpress site. They're running a few plug ins that are leading to Fatal Memory errors. The Two plug ins particularly are Simple Map & Drain Hole.I don't know which of those plug ins exactly is leading to the problem. Simple Map can be used to handle locations or companies, similar to Google Places. Drain Hole can be used to safeguard files via URL cloaking.

Within Simple Map, they presently have about 900 locations. Within Drain Hole they presently have about 700 files protected. Throughout development, we'd no issues whatsoever, as our PHP memory limit was set to 64MB. On their own live server, the host only enables 30MB, and won't allow this to become transformed.

My problem/real question is this: Basically move them to a different host, one which enables atleast 64MB, how do i make sure that when they continue to increase individuals plug ins, this won't happen again? Can there be anyway to check if these memory spikes are legitimate, or maybe they are due to poor, inefficient code?

EDIT: The fatal error appears to become a guessing game. It only occur in certain screens from the Wordpress Admin panel, particularly individuals coping with Simple Map. Although basically disable the Drain Hole wordpress plugin, the mistake disappears completely. The mistake:

**Fatal error:** Out of memory (allocated 34078720) (tried to allocate 44 bytes) in /fake/dir/wp-includes/wp-db.php on line 1400

1and1 is well known to be a poor Wordpress host. Wordpress 3.1 attempts to allocate 64megs to itself when run, as well as in wordpress-config.php, you can include this line close to the top

define('WP_MEMORY_LIMIT', '128M');

to seize more, if your host enables it. Get a new host, if at all possible. You are running plug ins within an intensive manner that will need much RAM. It might be a fault from the plug ins as well as Wordpress, but that is the actual way it is.

I understand this happens with buggy plug-inches. Regrettably, it requires turning them off 1 by 1, to determine what plug-was responsible. But next plug-was deactivated, you'll be fine.

Which was my solution after i received that same error.