I've just installed ffmpeg on ubuntu by using this guide http://ubuntuforums.org/showthread.php?t=786095, after i execute the ffmpeg command proven below, it works fine in terminal and delay pills work after i execute the php file I'm using with the terminal using the 'php' command.

After I attempt to execute the file utilizing a browser, however, I recieve the next error during my apache error log. If anybody could produce guidance, I'd really be thankful.

ERROR

/usr/local/bin/ffmpeg: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (needed by /usr/lib/i386-linux-gnu/libstdc++.so.6)

PHP code

define('FFMPEG_LIBRARY', '/usr/local/bin/ffmpeg')

$command = spend_professional('/usr/local/bin/ffmpeg -i /home/geoff/Desktop/cave.wmv file -acodec libfaac -aq 100 -vcodec libx264 -preset slow -crf 22 -threads /home/geoff/Desktop/newvideo.flv')

It appears like you have some dependency version issues. I am speculating you replicated the libraries from another server that was utilizing a different version from the core system files than that one does.

Your best choice would be to build from source around the machine you are utilizing it from. Which will make sure that your libraries aren't connecting to something which is not present in your system.

EDIT
And really, the mention of the /opt/lampp makes me believe that you are not while using standard webserver install that you simply would with an Ubuntu server, but they are rather using lampp. That may cause your conflict -- when the lampp stuff is related in a different way compared to "normal" system libraries, then you will possibly not have the ability to rely on them together.

This labored for me personally.

http://blog.codyjung.com/2011/05/29/problems-with-lampp-and-professional/

I went into /usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2

and replicated the libgcc_s.so into

/opt/lampp/lib and re-named it to libgcc_s.so.1 to overwrite the prior file

The consumer your internet server is running under doesn't have exactly the same atmosphere as the terminal user. You will have to add /opt/lampp/lib towards the web server user's atmosphere. Search for /opt/lampp/lib in /etc/ld.so.conf and also the files in /etc/ld.so.conf.d. When not there, create a new file in /etc/ld.so.conf.d having a line that contains exactly that path. You will have to restart the net server.

Searching only at that publish: http://fedoraforum.org/forum/showpost.php?p=1375187&postcount=2

Personally i think your condition might be solved, try setting up PHP from APT-GET rather than LAMPP and find out will it solve your condition.

You will get PHP,APACHE &lifier MySQL by:

sudo apt-get install apache2, libapache2-mod-php5, php5, mysql-client, mysql-common, mysql-server
- http://rakeshsankar.wordpress.com/2010/09/10/install-setup-debian-server/