i'm presently learning about clean web addresses. i had been using home windows once. i switched to ubuntu when all of a sudden my .htaccess appears to become no longer working here's my htaccess

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>

and so i have this url

http://localhost/index.php/my_name/

i had been planning on the 'my_name' string within the browser

hello my_title

however it would only work whenever i give a '?' within the uri

http://localhost/index.php?/my_name/

i think mod_rewrite is enabled. i even checked my phpinfo()

It may sound such as the rewrite module is disabled. Edit your apache configuration and load the dynamic module for mod_rewrite if available. It might seem like this:

LoadModule rewrite_module modules/mod_rewrite.so

If you are using Ubuntu, run sudo a2enmod rewrite make it possible for the module following by restarting the Apache server:

sudo /etc/init.d/apache2 restart

Found an answer. left the $_SERVER variable and used the REQUEST_URI index since QUERY_STRING doesn't display anything. will +1 Lekensteyn's answer because it brought me right path