I'm presently battling using the following problem.

I've effectively installed Apache2 and PHP5. And delay pills work until I alter the DocumentRoot from the Apache2 to different things than /var/www.

I wish to set the DocumentRoot to /home//wwwroot, but after carrying this out all php pages are simply whitened. (no download message or sth.)

Here's my php5.conf:

<IfModule mod_php5.c>
   AddType application/x-httpd-php .php .phtml .php3
   AddType application/x-httpd-php-source .phps
#    <FilesMatch "\.ph(p3?|tml)$">
# SetHandler application/x-httpd-php
#    </FilesMatch>
#    <FilesMatch "\.phps$">
# SetHandler application/x-httpd-php-source
#    </FilesMatch>
    # To re-enable php in user directories comment the following lines
    # (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
    # prevents .htaccess files from disabling it.
    # <IfModule mod_userdir.c>
        # <Directory /home/*/public_html>
            # php_admin_value engine Off
        # </Directory>
    # </IfModule>
</IfModule>

I dont have it, and want help.

Thx!

Do this rather. Avoid using AddType, as that breaks content settlement.

LoadModule ...
<IfModule php5_module>
    #PHPIniDir "/whatever/"

    AddType text/html .php .phps
    AddHandler application/x-httpd-php .php
    AddHandler application/x-httpd-php-source .phps

    <Directory /home/*/public_html>
        php_admin_value engine Off
    </Directory>
</IfModule>

PHPIniDir is essential if you wish to make use of a different ini apply for different php version, different website, server, etc. i would not remove it, i've got a different ini files for windoze, for osx as well as for linux.