While rebuilding some database backup copies I observed that pg_dump is really using Card inserts instead of COPY. I'm not even indicating -d flag but it is still using Card inserts for each database / table I attempt to dump and that's why reinstates take hrs instead of minutes.

Based on the pg paperwork pg_dump should use COPY automatically however in my situation it isn't. It is possible to method to ensure pg_dump uses COPY ?

Here's the pg_dump command:

pg_dump -Fp -t some_table -h localhost -d thisDB -f /some_dir/bkup

Any ideas ?

Thx.

you are indicating -d !!!!!:

pg_dump -Fp -t some_table -h localhost -d thisDB -f /some_dir/bkup
                                      ^^^^

Fortunately -d is no more.

Within the command line you published, you're in fact indicating the -d flag, even though it appears that you simply use it to specify the database to make use of. Try the next rather:

pg_dump -Fp -t some_table -h localhost -f /some_dir/bkup thisDB