I am attempting to enable .htaccess files on the Ubuntu server I setup. I transformed the websites file from:

<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
    	Options FollowSymLinks
    	AllowOverride None
    </Directory>
    <Directory /var/www>
    	Options Indexes FollowSymLinks MultiViews
    	AllowOverride None
    	Order allow,deny
    	allow from all
    </Directory>

    [unnecessary config code omitted]

</VirtualHost>

to

<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/document_root
    <Directory />
    	Options FollowSymLinks
    	AllowOverride None
    </Directory>
    <Directory /var/www/document_root>
    	Options Indexes FollowSymLinks MultiViews
    	AllowOverride All
    	Order allow,deny
    	allow from all
    </Directory>

    [unnecessary config code omitted]

</VirtualHost>

Now after i attempt to notice a page during my browser I recieve a 500 Internal Server Error. Any ideas in regards to what my problem might be? Just help.

EDIT

Here's my .htaccess file:

RewriteEngine on
RewriteCond $1 !^(index\.php|images|css|js|robots\.txt|favicon\.ico)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php/$1 [L]

I checked the apache error logs as asked for also it seems the error being drenched is:

[Comes to an end Jul 10 19:39:12 2009] [alert] [client 192.168.1.1] /var/www/document_root/.htaccess: Invalid command 'RewriteEngine', possibly misspelled or based on a module not incorporated within the server configuration

Bah... I did not have mod_rewrite enabled. Personally i think stupid.