I attempt to compile mod_wsgi with Cool Stack 1.3.1 around the Solaris platform:

export PATH=/usr/sbin:/usr/bin:/usr/local/bin:/usr/sfw/bin:/usr/ccs/bin

FLAGS="-I/opt/coolstack/include" LIBS="-lintl -lgettextlib" \
LD_LIBRARY_PATH=/opt/coolstack/lib LDFLAGS="-L/opt/coolstack/lib -R/opt/coolstack/lib" \
./configure --prefix=/usr/local/mod_wsgi \
--with-apxs=/opt/coolstack/apache2/bin/apxs \
--with-python=/opt/csw/bin/python

I recieve this error message:

# make
/opt/coolstack/apache2/bin/apxs -c -I/usr/local/include/python2.6 -DNDEBUG  mod_wsgi.c -L/opt/coolstack/lib -R/opt/coolstack/lib -L/usr/local/lib -L/usr/local/lib/python2.6/config -lpython2.6 -lsocket -lnsl -lrt -ldl -lm
/opt/coolstack/apache2/build/libtool --silent --mode=compile cc -prefer-pic -DSSL_EXPERIMENTAL -DSSL_ENGINE -xO4 -xtarget=generic  -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -I/opt/coolstack/apache2/include  -I/opt/coolstack/apache2/include   -I/opt/coolstack/apache2/include -I/opt/coolstack/include  -I/usr/local/include/python2.6 -DNDEBUG  -c -o mod_wsgi.lo mod_wsgi.c && touch mod_wsgi.slo
/opt/coolstack/apache2/build/libtool: line 1320: cc: command not found
apxs:Error: Command failed with rc=65536

Wrong?

You do not have SUN C/C++ compiler installed. The Awesome Stack packages have been constructed with that compiler and never gcc as well as in the situation of Apache apxs/libtool, that's most likely hardwired in to the tools. Thus, when individuals tools are utilized, they'll fail as aren't able to find that compiler.

Note that it's insufficient simply to change 'cc' to 'gcc' because the tools are particularly set up for that compiler under consideration and employ different choices based on which compiler it had been set up for. Quite simply, it's not dynamic, with your information only completed once the tools are configure/installed.