I set my database to want ssl. I have confirmed I'm able to connect with the db via command line by passing the general public key [and also have confirmed I can not connect if I don't pass public key]

I recieve exactly the same error during my django application as when I don't pass a vital. It appears I have not setup my configurations.py properly to pass through the road to the general public key.

Wrong with my configurations? I am using python-mysqldb.

DATABASES['default'] = {
    'ENGINE': 'django.db.backends.mysql',
    'HOST': 'my-host-goes-here',
    'USER': 'my-user-goes-here',
    'NAME': 'my-db-name-goes-here',
    'PASSWORD': 'my-db-pass-goes-here',
    'OPTIONS': {
        'SSL': '/path/to/cert.pem',
    }
}

Found the solution. OPTIONS need to look such as this:

'OPTIONS': {'ssl': {'ca':'/path/to/cert.pem',},},

Make certain you retain the commas, parsing appeared to fail otherwise?