We do hope you are great. I've Xammp on fedora and transformed who owns opp/lampp/htdoc to root. Why Used to because whenever someone produces new folder through discussing, they do not have permission to dynamically create folder or files in order to write images. I Quickly run command

chmod -R 777 /opt/lampp/htdocs

However when system would go to restart i quickly again have to run this command. So avoid over and over run this command I transformed the dog owner on "opt/lampp/htdocs" and run

chmod -R 777 /opt/lampp/htdocs

Now, whenever server restarts, designated permissions don't have to be set over and over. That's resolved.

I've an problem, the old sites may be used to write something. But when any network user produces new directory under htdocs, that new directory must be transformed the permission for this.

  • formerly produced, and may use that one directory to operate script to produce files

    drwxrwxrwx   2 root root     4096 2011-06-15 14:09 aaa
    
  • Recently produced, cannot be employed to operate a script to produce image in order to write anything

    drwxr-xr-x   2 root root     4096 2011-06-17 15:17 aaaa
    

drwxr-xr-x that one is actually annoying in my experience for every recently produced folder in htdocs :(

Just to show you that my htdocs user and privileges are:

 drwxrwxrwx 101 root root  4096 2011-06-17 15:17 htdocs

Why do so? Can anybody help me to find this issue out? I'm awaiting quick response anxiously.

To begin with, you need to investigate what permissions you actually need - chmodding everything to 777 is really a security risk because it allows any user to create inside your web root.

However, to deal with your actual question from the default permissions whenever a new folder is produced with a user, you need to adjust the default "umask" which determines may be.

This has some good info for altering it for that Apache user (if your "network user" is really a user creating new files and sites with the httpd process):

Setting the umask from the Apache user

If you want to adjust it for other customers or processes, the answer is going to be similar.

Best of luck!

Edit

Since you are on Fedora, do this: (in the question I linked above)


[root ~]$ echo "umask 002" >> /etc/sysconfig/httpd

[root ~]$ service httpd restart

The very first command will prove to add that line towards the /etc/sysconfig/httpd the industry permanent configuration file, and also the second command can make it active.

You're dealing with the issue in the wrong side. Reinstate your apache configuration to make use of apache.apache as default user/group, and hang your samba server to make use of individuals qualifications when someone email your document root.

If you work with nfs or any other posix compatible filesystem, use chmod g+s to help keep all files readable out of your apache server.

Check it out:

#umask 000

have fun!!