I've lately installed Redmine on my small Ubuntu 11.10 box at work, and also have it working fine from localhost/redmine. Now i'm attempting to put it on the internet for other people during my office to make use of but am encountering a hitch somewhere. I just read through multiple threads but haven't found an answer. The most recent factor was appending

Redmine::Utils::relative_url_root = "/redmine"

I have attempted being able to access it via my http://2222.us/redmine only receive connection timeout errors. The items in my httpd.conf is simply one line

ServerName 127...1

Port 80 IS listening

# netstat -nao grep 80

tcp ...:80 ...:* LISTEN off (.00//)

And also the items in my sites-enabled apply for Redmine is

<VirtualHost *:80>
    ServerAdmin jd@neongecko.com

    DocumentRoot /var/www
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    # See 
    # http://www.modrails.com/documentation/Users%20guide%20Apache.html 
    # for details on what these options do.  They will lead to an increase
    # in memory usage, but significantly reduced access times.


    # Speeds up spawn time tremendously -- if your app is compatible. 
    # RMagick seems to be incompatible with smart spawning
    PassengerSpawnMethod smart


    # Keep the application instances alive longer. Default is 300 (seconds)
    PassengerPoolIdleTime 300


    # Additionally keep a copy of the Rails framework in memory. If you're 
    # using multiple apps on the same version of Rails, this will speed up
    # the creation of new RailsAppSpawners. This isn't necessary if you're
    # only running one or 2 applications, or if your applications use
    # different versions of Rails.
    RailsFrameworkSpawnerIdleTime 0

    # Just in case you're leaking memory, restart a listener 
    # after processing 5000 requests
    PassengerMaxRequests 5000


    # Only check for restart.txt et al up to once every 5 seconds, 
    # instead of once per processed request
    PassengerStatThrottleRate 5

    # Specify the minimum number of instances passenger can keep
    # while cleaning idle instances
    PassengerMinInstances 3

    <Location /redmine>
        Options Indexes -ExecCGI FollowSymLinks -MultiViews
        # AllowOverride None
        Order allow,deny
        Allow from all

        # mod_rails
        # PassengerUser redmine
        #RailsEnv edoceo_live
        RailsBaseURI /redmine

        # environment.rb
        # Redmine::Utils::relative_url_root = "/redmine"    
    </Location>

</VirtualHost>

# Then after the virtualhost is loaded, send it a request
# to initialize the redmine installation
PassengerPreStart http://2222.us/redmine/

It ought to be working nevertheless its not? Can someone advise?

You might have firewall issues here, or even more likely you have to setup port sending in your router to forward traffic on port 80 for your linux box.

God I am stupid, I had been while using wrong ip.....