During my content I am giving my <h3> tags id's with regard to direct connecting.

This is the way it appears within the publish editor:

<h3 id="h3-title">H3 Title</h3>

To ensure that I'm able to directly connect to it such as this:

<a href="http://example.com/page#h3-title">H3 Title</a>

However, the double quotes are becoming steered clear of in some way, using the html output around the publish page searching such as this:

<h3 id="\"h3-title"\">H3 Title</h3>

This will make the hyperlinks not work :(

I have attempted to produce, for example getting rid of the wptexturize filter in the_content, ensuring miracle_quotes were off, as well as remove_filter('content_save_pre', 'wp_filter_post_kses'); which breaks things wonderfully.

I am seriously thinking about just developing a filter to get rid of the slashes, however it appears they should not happen to be added to start with. They are not put into images with id's, for instance, so they ought to be added somewhere. This occurs both in visual and html modes.

Any help could be greatly appreciated.

I am thinking this might be a wordpress plugin interaction. I simply produced an easy test publish on my small Wordpress website, and it didn't escape the quotes. This really is was using blogging platforms 2.9.1.

You've most likely fixed this already, however for individuals searching google for that response to remove double steered clear of quotes in php, make certain the written text is first strained through stripslashes($data) function first.

I have observed when you uncheck the "prevent connecting in heading tags (h1,h2,h3,h4,h5,h6)." within the configurations from the Search engine optimization Wise Links wordpress plugin, the rear slashes are removed. I have published this around the wordpress plugin author's page to hopefully be fixed.

For anybody that results in this, the Search engine optimization Wise Links wordpress plugin could be fixed by modifying the SEOLinks_the_content_filter function.

Replace

$result=$this->SEOLinks_process_text($text, 0);

With

$text = stripslashes($text);
$result=$this->SEOLinks_process_text($text, 0);
$result = stripslashes($result);

I am no php expert, no clue if this sounds like the perfect fix, however it labored for me personally. It was an altered fix available on http://www.prelovac.com/vladimir/forum/plugins/seo-smart-links-fix-for-you-seo-smart-links-plugin