In a single of my CakePHP site, I acquired this error.

Request Entity Too Big

I'm not sure what's the problem. I believe the information that i'm posting through form is simply too large. I looked this in internet search engine and also got which i will need to increase post_max_size. Be default It is placed to 8M.

Try not to understand how to increase post_max_size in CakePHP and how to proceed for this?

Thanks.

post_max_size and [cde] are PHP.ini configurations. You are able to set them either directly in PHP.ini or via [cde]. I'm not sure if this is often set with a few Cake-internal tools too.

However, the mistake may be triggered with a set limit of the RequestBodyLength in Apache (presuming you're running under Apache).

I want to create that within the PHP config file, php.ini. For those who have a VPS / root level access, just in the size on that. If you do not (hosting that is shared), you are able to customize the php ini parameters at runtime. Observe that ini_set() will not work here, since the PHP configurations are loaded past too far (following the file continues to be submitted, the PHP script starts execution).

You will need to range from the following inside your htaccess file (on hosting that is shared):

upload_max_filesize

It is possible this will not work. Some searching around managed to get appear as if some shared hosts will lock lower this setting, which makes it not over-rideable in htaccess (just in primary server config). If that is the situation, you will need to move hosts.

Sometimes on hosting that is shared you can include your personal php.ini file - just copy the appropriate bits from any default file (or google for just one).

It isn't a mistake I have seen before - it might as Gordon states, be Apache.

You shouldn't be afraid to request the hosting support team - I have always found them to be really useful (I believe they have to get lonely), and frequently they'll make config changes for you personally.

It certainly is not a CakePHP problem.