Options +FollowSymlinks

RewriteEngine on

RewriteCond %{REQUEST_FILENAME} !-f # not a file
RewriteCond %{REQUEST_FILENAME} !-d # not a directory
RewriteRule ^(.+)$ index.php?params=$1 [L]

as you can tell, i am attempting to convert anything like

mysite.com/x/y/z

to

mysite.com/index.php?params=x/y/z

however, it's not working. i attempted mysite.com/home and set a breakpoint around the first line in index.php, but got a 404.

any ideas why this is not employed by me? thank you for anything!

First, make certain mod_rewrite is enabed in your Apache server.

Then take away the comments in the finish from the lines:

# not a file
RewriteCond %{REQUEST_FILENAME} !-f
# not a directory
RewriteCond %{REQUEST_FILENAME} !-d

In the Apache documentation:

Lines which start with the hash character "#" are thought comments, and therefore are overlooked. Comments might not be incorporated on the line following a configuration directive.

It appears, that either mod_rewrite isn't installed, or enabled, or you have set the AllowOverride-directive for that specific directory to None. Change it out to (a minimum of) FileInfo