I am presently moving my Ruby on Rails 2.3.8 applications to a different server running Apache 2.2.17 on FreeBSD 8.1 with Passenger 3, Ruby Enterprise Edition 1.8.7. For whatever reason, regardless of the stylesheets being accessible, the applications aren't loading them. The code is correct and runs fine around the old setup. Has anybody went into this?

Update: Wowwww it had been an problem using the version of chromium. All is nice after upgrading. Just help everybody.

I'd check up on the permissions -- what user may be the ruby process running under (for passenger), and does that user have the stylesheet under consideration.

you should use ls -l to determine permission sets for that stylesheets.